MaMo Net



#1 24.08.2009, 21:48
Yeti Abwesend
Mitglied
Dabei seit: 24.08.2009
Beiträge: 2


Betreff: Problem bei mehrzeiligen Smilies
Beim Light Smiliegenerator taucht plötzlich ein Problem bei mehrzeiligen Smilies auf. Der Text wird nicht im schild angezeigt. In der Vergangenheit funktionierte das seltsamerweise. Ich habe mal einen Smilie in der Testversion hier erstellt, das Problem ist das selbe wie auf meinem Server. Ich habe keine Abhängigkeit von der Größe der Schrift festgestellt. Nur die Zahl der Textzeilen scheint relevant zu sein.

↑  ↓

#2 24.08.2009, 22:38
MaMo Abwesend
Administrator
Dabei seit: 06.04.2004
Beiträge: 2.673


Betreff: Re: Problem bei mehrzeiligen Smilies
Du hast recht, danke für den Hinweis. Das muss ich mal untersuchen, das ging ja schonmal... *grübel*
Matthias M.
=> Support nur per Forum - dann haben alle etwas davon!
↑  ↓

#3 24.08.2009, 23:05
Yeti Abwesend
Mitglied
Dabei seit: 24.08.2009
Beiträge: 2


Betreff: Re: Problem bei mehrzeiligen Smilies
Bei mir auch. Und ich habe seither nix verändert... Computer haben eben scheinbar ein Eigenleben.
↑  ↓

#4 24.08.2009, 23:13
MaMo Abwesend
Administrator
Dabei seit: 06.04.2004
Beiträge: 2.673


Betreff: Re: Problem bei mehrzeiligen Smilies
Naja, nichts verändert... das kann man so nicht sagen. Es kann ja an allem möglichen liegen, einem Browser-Update oder eine neue PHP-Version oder ... da gibts so viele Möglichkeiten!
Matthias M.
=> Support nur per Forum - dann haben alle etwas davon!
↑  ↓

#5 27.08.2009, 06:36
TNS
Gast


Betreff: Re: Problem bei mehrzeiligen Smilies
wollte ich doch auch glatt das Teil auf einer meiner Seiten einfummeln und sah das Problem mit dem mehrzeiligen Text. Melde dich mal wenn du das Problem gelöst hast, so wegen Pro-Version und so Wink

so delle ...
TNS
↑  ↓

#6 27.08.2009, 21:55
MaMo Abwesend
Administrator
Dabei seit: 06.04.2004
Beiträge: 2.673


Betreff: Re: Problem bei mehrzeiligen Smilies
Hi TNS,

was macht das WSB? Stell das mal wieder online Grinning
Hab mich dem Fehler genähert, scheint an der PHP-Version zu liegen, denn ab 5.2.10 gibt es eine modifizierte imagettfbbox-Funktion und die rechnet anders als vorher. Ich mach mich mal an einen Bugfix... (inkl. Kompatibilität für PHP 5.3).

Mit freundlichen Grüßen MaMo
Matthias M.
=> Support nur per Forum - dann haben alle etwas davon!
Dieser Beitrag wurde 1 mal editiert, das letzte Mal am 28.08.2009, 16:10 von MaMo. ↑  ↓

#7 28.08.2009, 04:23
TNS
Gast


Betreff: Re: Problem bei mehrzeiligen Smilies
Test OT-Code Laughing
Off-Topic:
ja das WSB ... derzeit hab ich soviele Baustellen das ich nicht wirklich weiss wo ich zuerst den Spaten schwingen soll. Aber ich hoffe das ich es dieses Jahr noch irgendwie geregelt kriege. Muss halt in erster Linie aufs Geschäft gucken Wink

wegen dem Generator ... bei mir läuft derzeit die PHP Version 5.2.6 ... aber zukunftskompatible wäre schon keine schlechte Sache Grinning

so delle ...
Andreas
↑  ↓

#8 28.08.2009, 07:23
MaMo Abwesend
Administrator
Dabei seit: 06.04.2004
Beiträge: 2.673


Betreff: Re: Problem bei mehrzeiligen Smilies
Hi!

Nachträgliche Anmerkung des Autors:
Es liegt an der neuen PHP-Version 5.2.10 im PHP 5.2er Branch, PHP 5.3 ist wieder in Ordnung. Im SVN-Archiv von PHP gibt es bereits ein Bugfix für Version 5.2.11, konnte ich bisher aber noch nicht testen. Ob ich dafür einen Bugfix basteln kann kläre ich noch.

5.3.0 / Win: OK
5.2.11: Bugfix in SVN, bisher nicht getestet
5.2.10 / *nix: FEHLER - PHP Änderung an imagettfbbox()
5.2.9: OK

Mit freundlichen Grüßen MaMo

Off-Topic:
@TNS: Und was mache ich jetzt, wenn ich Langeweile habe? Im WSB hab ich immer eine von deinen Flash Breakout Spielen gespielt Grinning

Matthias M.
=> Support nur per Forum - dann haben alle etwas davon!
Dieser Beitrag wurde 5 mal editiert, das letzte Mal am 28.08.2009, 17:25 von MaMo. ↑  ↓

#9 28.08.2009, 22:31
MaMo Abwesend
Administrator
Dabei seit: 06.04.2004
Beiträge: 2.673


Betreff: Re: Problem bei mehrzeiligen Smilies
Tja, keine Chance... ein Fehler in PHP ist leider nicht so einfach auszubügeln, besonders wenn dahinter eine komplexe Grafikbibliothek steckt. Da können wir nur warten, bis eine neue Version rauskommt, aber in 5.2.11 ist das schon behoben (siehe php.net Bugtracker).
Matthias M.
=> Support nur per Forum - dann haben alle etwas davon!
↑  ↓

#10 14.11.2009, 10:15
MaMo Abwesend
Administrator
Dabei seit: 06.04.2004
Beiträge: 2.673


Betreff: Re: Problem bei mehrzeiligen Smilies
Lt. PHP Bugtracker ist der Fehler nur existent in der Version 5.2.10 und 5.3.0, alle anderen Versionen sollten hoffentlich funktionieren.
Matthias M.
=> Support nur per Forum - dann haben alle etwas davon!
↑  ↓

Seiten (2): 1, 2


Alle Zeitangaben in GMT +02:00. Aktuelle Uhrzeit: 17:30.