MaMo Net



#1 12.03.2008, 20:13
Azerus Abwesend
Mitglied
Dabei seit: 02.03.2008
Beiträge: 39


Betreff: Fragen zu plugins/pakete
hi,

ich habe ein paar fragen zu plugins/pakete.

So ich möchte mein Forum mit einigen eigene plugins bzw ganzen Paketen erweitern.

Nun meine frage (Problem) liegt darin ich möchte gerne das sich die boxen meiner plugins sich genauso Auf und Zuklappen lassen wie z.b. die Forum Kategorien, "Wer ist Online?" und "Legende".

Wenn ich mich nicht irre muss ich nur eine entsprechende id für die jeweilige box festlegen und diese dann im jeweiligen Templates übernehmen.
Nun kann ich in der package.ini diese ID irgend wie festlegen?
Damit diese auf und zu klap funktion funktioniert oder geht das nur wenn ich es irgend wo im Forum script manuel anpasse?

So weiteres würde ich gerne die Box überschrieft eines meiner Boxen so verlinken wie die von "Wer ist Online?".
Das genaus so eine art erweiterte ansicht geöffnet wird wie es bei "Wer ist online?" ist.

Und zu letzt noch ist es möglich über pakete images/Bilder für die plugins mit hoch zu laden?

Hoffe ich konnte meine Fragen/Probleme verständlich erklären.^^

Mit freundlichen Grüßen
Azerus

Theorie: Man weiß wie es geht, es funktioniert aber nicht.
Praxis: Es funktioniert, aber man weiß nicht warum.
Microsoft vereint Theorie und Praxis: Nichts geht und keiner weiss warum!
↑  ↓

#2 13.03.2008, 14:09
MaMo Abwesend
Administrator
Dabei seit: 06.04.2004
Beiträge: 2.675


Betreff: Re: Fragen zu plugins/pakete
Hi,

das "Auf- und Zuklappen" musst Du in den Templates realisieren. Da guckst Du dir am besten mal einige Beispiele in den vorhandenen Templates an. Das Verlinken der Überschrift geht ebenfalls nur über die Templates, das ist ja nur ein simpler Links dann.

Das mitliefern von Bildern funktioniert wie folgt:
Die components.ini braucht eine Sektion images. Dort trägst du durchnummeriert die Dateinamen ein. Beispiel:
DownloadINI-Quelltext:
  1. [images]
  2. 0 = bild1.gif
  3. 1 = bild2.png
Die Bilder müssen im ZIP-Archiv im images-Ordner liegen, bzw. in der Viscacha-Installation dann im Standard-Images-Verzeichnis. Weiß leider nicht in wie weit das jetzt für dich verständlich ist...

Mit freundlichen Grüßen MaMo
Matthias M.
=> Support nur per Forum - dann haben alle etwas davon!
↑  ↓

#3 13.03.2008, 21:00
Azerus Abwesend
Mitglied
Dabei seit: 02.03.2008
Beiträge: 39


Betreff: Re: Fragen zu plugins/pakete
Hi,

also das mit dem Auf und zuklappen der boxen hab ich jetzt herraus gefunden.

Was das verlinken angeht. Wie ich die Überschrieft normal verlinke das eine neue seite geöffnet wird ist mir schon klar nur möchte ich das diese seite innerhalb des forum geöffnet wird. Wie bei "Wer ist Online?" darum geht es mir wie ich dies erreichen könnte.

Was das mit dem Bilder angeht das verstehe ich nur teils.
Das diese Bilder im Standart Image verzeichnis sein müssen versteh ich ja.
Nun aber wo ich jetzt die components.ini hernehme ist mir jetzt unklar.
Ich gehe mal davon aus, diese wird im packet benötigt wenn man ein Komponent hinzufügen will so in etwa wie man eine plugin.ini braucht um plugins hinzu zufügen.
Nun ja was Komponenten angeht hab ich wohl noch weniger schimmer als von plugins hinzufügen da ich nur soweit gehn kann wie ich es aus den schon vorhanden packeten bzw plugins herraus lesen kann.
Und nach diesen Vorlagen versuch ich eigene plugins zu schreiben.
Da es ja sonnst keine Beschreibung momentan gibt, wie man solche erstellt.

Ich habmal probe weise eine componets.ini ins packet gefügt aber anscheind hab ich wohl einiges an informationen vergessen.
Weshalb auch nicht das gewünschte ergebniss dabei herraus kam.

Mit freundlichen Grüßen
Azerus
Theorie: Man weiß wie es geht, es funktioniert aber nicht.
Praxis: Es funktioniert, aber man weiß nicht warum.
Microsoft vereint Theorie und Praxis: Nichts geht und keiner weiss warum!
Dieser Beitrag wurde 3 mal editiert, das letzte Mal am 13.03.2008, 21:05 von Azerus. ↑  ↓

#4 13.03.2008, 21:48
MaMo Abwesend
Administrator
Dabei seit: 06.04.2004
Beiträge: 2.675


Betreff: Re: Fragen zu plugins/pakete
Hi,

das mit den Links verstehe ich nicht ganz. Vielleicht wäre ein Beispiel zur Veranschaulichung gut.
Zu den Bilder: Was planst du denn genau? Du willst ein Paket schreiben, ja? und das soll u.a. auf einem Bild + Plugin bestehen. Mhh... vielleicht schreibst du mich mal per IM an, da lässt sich das besser klären.

Mit freundlichen Grüßen MaMo
Matthias M.
=> Support nur per Forum - dann haben alle etwas davon!
↑  ↓

#5 14.03.2008, 19:33
Azerus Abwesend
Mitglied
Dabei seit: 02.03.2008
Beiträge: 39


Betreff: Re: Fragen zu plugins/pakete
Ja ich möchte eine Paket schreiben und damit es anschaulicher ist möchte ich das ein oder ander kleine bild einfach aus design gründen dazu fügen. Und dazu meine frage ob ich beim upload des Paketes gleich die bilder mit hochladen kann ohne es umständlich manuel zu machen.

Wegen dem verlinken bleiben wir doch bei dem "Wer ist online?" Paket als beispiel.
Wenn man auf die Überschrieft klickt wird ja die misc.php geöffnet mit weiteren informationen über die User welche grad im Forum sind werden angezeigt und zwar in dem beriche wo vorher der eigentliche teil des Forum angezeigt wird, die Kategorien, Foren, Legende Box, Wer ist Online? Box und weiteres.
Und dies möchte ich auch für meine box erreichen momentan erreich ich nur das zwar die überschrieft verlinkt ist aber bei einen klick drauf ein neuer Tap in meinen Browser geöffnet wird ich will aber das die verlinkte seite im Forum unter dem Banner neben der Navigation aufgerufen wird. Wie die misc.php bei "Wer ist Online?".
Ich finde das eigentlich schöner statt das neue Browser Fenster bzw Taps geöffnet werden oder ich das mit einem Popup fenster löse.

Nachträgliche Anmerkung des Autors:

Noch was anderes, hat sich was in der Administration bei den Paketen geändert?
Seite dem update erscheint bei mir dieser Fehler beim uploaden eines Paketes.

Fehlermeldung:
* Das Packet benötigt mindestens Viscacha

Ich verstehe zum einen den Fehler nicht. Um zum anderen hat das selbe Paket ohne irgend welche nachträglichen Änderung vor dem update auch funktioniert hoch zu laden.

OK hat sich erledigt habs selber endeckt.
Hab grad in der packets.ini die minimale nötige version von "0.8 RC4" auf "0.8 RC4 pl1" anpassen müssen.

Nachträgliche Anmerkung des Autors:

Was das verlinken der box angeht hab ich mittlerweile selber eine Lösung gefunden ich habe einfach die misc.php soweit angepast das es etwa meinen Vorstellungen entspricht.
Na und das wegen den bildern, wie ist eigentlich ein Packet für eine Komponent den nun genau aufgebaut?

Theorie: Man weiß wie es geht, es funktioniert aber nicht.
Praxis: Es funktioniert, aber man weiß nicht warum.
Microsoft vereint Theorie und Praxis: Nichts geht und keiner weiss warum!
Dieser Beitrag wurde 5 mal editiert, das letzte Mal am 15.03.2008, 20:44 von Azerus. ↑  ↓

Seiten (1): 1


Alle Zeitangaben in GMT +01:00. Aktuelle Uhrzeit: 23:59.